2009-06-26

How to change kernel from 32 to 64 bit on AIX

if your IBMserver is 64 bit but it run at 32 bit
it can mount filesystem max 1 TB
if you want to use filesystem larger than 1 TB you can change kernel to 64 bit
1. Ensure currently kernel is running as 32 bit.
# bootinfo -K
32

2. Run these commands. Require system reboot, so let customer stop all applications first.
# ln -sf /usr/lib/boot/unix_64 /unix
# ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
# bosboot -ad /dev/ipldevice (ipldevice is hdiskx which is the boot disk)
# bootlist -om normal (list bootdevice)
# bosboot -ad /dev/hdisk0 or /dev/hdisk1
# shutdown -Fr

3. After reboot, verify kernel run as 64 bit.
# bootinfo -K
64

If we want to change back kernel from 64 to 32 bit. Use all steps above, but change the commands at step2.
# ln -sf /usr/lib/boot/unix_mp /unix
# ln -sf /usr/lib/boot/unix_mp /usr/lib/boot/unix
# bosboot -ad /dev/ipldevice (ipldevice is hdiskx which is the boot disk)
# shutdown -Fr